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Introduction

           

form the core of it’s operations.

It does handle:

        

e -10 disease codes for each patient admission. You can assign 
ase codes, and prioritise them (primary, secondary, etc..)

  

nts to different wards/beds

  

e scharge data (patient status at time of dscharge)

  

e

  

pancy rates as a whole and by ward

  

atistics

 

mSupply-HIS

 

 the HIS module are integrated, they also operate independ-
ble to use either module without using the other one.

 

de

 

r esigned for either printing or viewing within Acrobat Reader 
r. It requires Adobe Reader 6 or later (or Foxit Reader or the 
ac).

choose 

 

show bookmarks

 

 from the window menu. You can 
s e through the sections and chapters by clicking on a book-

 use the 

 

find

 

 command to find words and topics which inter-

r a comprehensive index, and if you are viewing the PDF ver-
e number in the index will take you to that page.

The soft er constant development. As new features and facilities are 
added, w  ensure that the user guide and the graphics that it contains 

h pments, but occasionally you may find that there are slight 
n the program itself and the manual or its graphics. These are 
ature, but should you have any difficulties, do please send us 
ils of your problem.

ompatible with both Windows OS and Apple Mac OS, there is 
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Thank you for choosing mSupply’s HIS module.

Before you launch in (if you haven't already!), we suggest you plan to take the 
following steps. 

• Read the rest of this introduction.

• Read the setup, tutorial and licence chapters in this manual.

• If you are not sure, why not try, and email us if you get stuck.

Why an HIS module for mSupply?
As mSupply has become more widely used, it has become clear to us that many 
hospitals that use mSupply now have a functioning computer system in their 
pharmacies, and not much anywhere else. Other clients have spent close to $1 
million on systems that we don’t think are financially justified in their environ-
ments.

By incorporating an HIS module into mSupply it allows a hospital to cover the 
basics while sharing a server with the pharmacy, so a hospital that uses mSupply 
can start using the HIS module with little or no extra hardware costs.

mSupply and the HIS module share a common patient database, meaning that 
the pharmacy and other hospital functions are integrated.

What does mSupply-HIS do?
First, we should say that mSupply-HIS is not a fully-fledged Hospital information 
system. It is designed to concentrate on a subset of a hospital’s activities that 
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• Patient registration and recording common static patient data.

• Recording a hospital’s wards and beds.

• Recording inpatient admissions (admitting a patient, assigning them to a 
ward and bed).

reflect t
differen
usually o
an e-ma

As mSup
a mix of



 

Introduction

                   

ot-for-profit organization 

  

ountry. 

  

 shall be the sole arbiter of those qualifying for free 

  

id)must register with Sustainable Solutions to obtain 
nformation supplied will not be used for any purpose 
n of registration code. 

  

ined a free licence number are not eligible for free 
e will sometimes choose to give support.

s regarding customised versions and installation and 

 

ersions

 

-HIS is version 3. This synchronizes the version num-
About us
Sustainable Solutions was established in 2001 with the primary aim of supplying 
and supporting mSupply software in developing countries. We are committed to 
producing software that enables excellence in health care delivery. We take 
pride in loo king after people and organisations who choose to use our services.

We are based in Kathmandu, Nepal and Auckland, New Zeland

We can be contacted at:

email:<info@msuppy.org.nz> or <info@sussol.net>

phone: 977 1 5548 021, fax: 1 (815)572-9431 

post: 

• PO Box 8975, EPC 355, Kathmandu, Nepal
• 6a Challenger St, St Heliers, Auckland, 1071, New Zealand

Please feel free to request more information.

Thanks
Lots of people have contibuted to make mSupply what it is. Most of the follow-
ing people have made positive contributions ;-)

Bandana Baidya, Craig Drown, Ujwal Khatry, Peter Laing, Sajan Ojha, John Ross, 
Leif-Erik Stabell.

Copyright

• in an approved n
• in a developing c

• Sustainable Solutions
use.

• All users (free and pa
a registration code. I
other than generatio

• Users who have obta
support, although w

Please contact us for quote
training packages.

Changes in recent v
The first version of mSupply
bers with mSupply.
mSupply-HIS software is copyright Sustainable Solutions, 2009-2010.
6

Licence Agreement and Free use conditions
Commercial users or any user wanting multi-user functionality enabled must 
obtain a licence from Sustainable Solutions.

Please view our web site http://www.msupply.org.nz for up-to-date pricing.

Non-commercial use

• You may use mSupply software in single user mode for free as long as it is 
used:



 

Changes in recent versions
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Conventions used in this manual

                                

Drop-down list

 

A list that is shown when you click on an item. The item you choose becomes the 

   

n

 

i in a field that indicates which field is currently accepting 

 

o

 

 be operated by pressing the "Enter" key,.

  

c an be controlled by holding down "CONTROL" ("COM-
nd pressing the period key (full stop).

  

  is a way of describing where a document is stored on your 
en as "hard disk:folder 1: folder 2:document", which is the 

 \folder 2\document". 

 

r

 

 have different

 

 

 

modifier keys. We've tried to list both in the 
, imes one might slip through, so

TROL" key does the same as the "COMMAND" (cmd) key on 

" key does the same as the "OPTION" (opt) key on Macs.

 

 

 

 headings can be clicked to sort the list by that item..
 point
nking line 
put.

n
button can

utton
el button c

 on Macs), a

a file
document)
k. It is writt
"C:\folder 1

 keys
s and Macs
 but somet

dows "CON

dows "ALT

headings
ply column
If you aren't familiar with using a computer, you should read this chapter, and 
also work through the tutorial.

Menus
Choose new item from the Item menu (sometime also written as Choose Items ) 
New item  means.... Click on the word item in the menu bar, then choose new 
item from the menu that drops down.

Field
An area where you can make an entry, either text or numbers - usually a white 
coloured box.

Moving between fields
You can move from field to field by using the TAB key. Holding down the SHIFT 
key while pressing the TAB key will move you from field to field in the reverse 
order to normal. (Note that on Windows, some buttons are "tabable"- that is, 
pressing the tab key moves the "focus" (the active area) to a button. Pressing 
the "return" key then activates that button.)

Check box
is a box that changes from having an "X" in it to being blank each time you click 
in it. To "check" a check box means to click it so that an "X" appears (if there is 
not one already present). Check boxes have text beside them explaining what 
the box is for.

Highlighted button
Pressing the ENTER key will operate the highlighted button in a window, which 
is usually the OK button.

Insertio
is the bl
typed in

OK butt
The OK 

Cancel b
The can
MAND"

Path to 
(Or to a
hard dis
same as

Modifie
Window
manual

The Win
Macs

The Win

Column
In mSup
current choice for that list. Only one item can be chosenat a time.

Double-click
In lists (e.g. of Names or of Items), double click the left mouse button on a line to 
edit or view more details.
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Macintosh

        

orage of backups.

a e backed up data off-site to prevent the risk of loss by 

the use of RAID 5 and mSupply’s automated internet 

 will not be able to help you if you have hardware 
e a backup.

 

ndations:

  

t is not absolutely necessary in every situation, but for 
 requirement.

  

ich you are able to obtain good support.

  

putation for quality (even if it means buying a slower/

  

c ing mSupply on a wide range of hardware. We are 
ware options further via email or phone.

 

e off-site st
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 do not hav
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ed printer 
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lients runn
discuss hard
Setting up mSupply-HIS

Hardware requirements:

Windows
Hardware requirements vary widely depending on what you want to use mSup-
ply for 

Here’s a rough guide.

If you have an older operating system, please contact us for an old version of 
mSupply that runs on Windows 98 or later.

USB2 to facilitat

You need to be 
fire, theft, etc.

For servers we re
backup system.

Note! Sustainab
failures and you

Hardware r

• A connec
most situa

• Buy hardw

• Buy brand
older mac

• We have 
happy to 

Absolute minimum Windows 2000 or XP computer with 
a 500 Mhz Pentium processor or 
equivalent.

Suggested single user 
or Client machine for 
use with server.

Win 2000 or later, 800 Mhz or faster 
Pentium processor or equivalent, 
256Mb RAM

Suggested server Win XP/2003 or later, 1.4Ghz Pen-
tium 4 or equivalent, 1Gb or more 
RAM. 2 Hard disks. Attached to Uni-
terrupted power supply (UPS) unit 
with software to shut down server if 
battery power is about to run out.
8

• Mac OS X 10.5 or later.

• 50Mb hard disk space.

• 1024 x 768 or better screen resolution.

Backup system
Once you start using mSupply, it is of crucial importance that you have a method 
of backing up your data. mSupply stores all its data in a couple of files that rap-
idly become large if you are entering a lot of data. You need, therefore, to have 
a high capacity removable storage device for off-site backups. We strongly rec-
ommend the use of an external hard disk using either firewire (IEEE 1394) or 
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Single user setup

              

use the tutorial at the start of the manual to learn the basics quickly) 

              

u  to begin!

 

le

 

ler treats example data files in a special way. Re-installing 
ous installation will replace all the files except the example 
revent valuable data from being deleted as users may have 

tual stock into the example data file. 

l py of the example data file on windows you can carry out 
mentioned below :

  

upply using the Windows menu 

 

Start > Program Files > mSup-
l ll mSupply . 

 

This will remove all installed files of mSupply 
es the example data files. Re-installing mSupply now will 
 copy of the example data file.

  

o ually delete the example data file and re-install mSupply. The 
aller will install a fresh copy of the example database as the 

r  does not exist.

i ines, simply replace the example folder from the mSupply 

 

f ws users

   

al settings

 

 in control panel, make sure the short date format is 
 only 2 digits for the year (YY, not YYYY). mSupply lists are set 

p nly enough space for 2 digits. Having the wrong seting here 
ct display, not the actual data. It does 

 

not

 

 matter if you use 
r MM/DD/YY or YY/MM/DD

  

  of lists in mSupply overlaps the separator lines, turn off 

 

large 
fo

  

isplay

 

 control panel. 

 

ply for the first time

 

ither 

  

o the 

 

start mSupply icon

 

 on your desktop, or 
 are ready

le Data fi
pply instal
 on a previ
. This is to p
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l a fresh co
he options 

ninstall mS
y > Uninsta
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uble-click 
Upgrading from previous versions
If you open a data file that was created with a previous version, it will automati-
cally be updated to the new format. Please note that this process may take some 
time.

IMPORTANT! Always make a backup of your data file before upgrading. We will 
not be able to help you in the event of some unexpected disaster if you haven't 
followed this advice.

Single user Installation
For client/server installation instructions, please contact Sustainable Solutions.

We are assuming you have obtained mSupply either via the Internet.

If you have downloaded the file you need, and you have saved it to your desk-
top, it is important that you saved the file with an ".exe" extension or it will not 
run (You can rename a file by right-clicking on it). The default name for the file 
is "mSupply_installer.exe"

It is strongly recommended that users who are not familiar with program instal-
lation adhere to these directions.

• Double-click "mSupply_installer..exe", and it will automatically run the 
mSupply installer. 

• The installer will do the following:
• Create a folder on your chosen drive called "mSupply" 
• Create in the mSupply folder a sub folder called "example folder" con-

taining an example data file. You can use this data file for practice. (Or 

Now yo

Examp
The mSu
mSupply
data file
started e

To insta
one of t

• U
p
w
in

• Y
m
p

On Mac
installer

Notes 
• In

se
u
w
D

• If
• Install the "mSupply.exe" application and associated files. Double-
clicking this file will do the same as double-clicking the "start mSup-
ply" icon on your desktop.

• Install "mSupply manual....pdf" -this document.
• Create two shortcuts on your desktop: "start mSupply" and "mSupply 

user guide.pdf"
• Create a "mSupply folder" entry in the "programs" section of your 

"start" menu.

Starti
To start 

• d



 

Single user setup

                     

utton in the bottom right coner of the window. 
l open where you can choose the location and name 

up a particular data file, that file becomes the default 
atically on restarting mSupply. To use a different file, 
ed later. If the default data file is renamed or moved 

ust be openedusing its new name or location. 
• choose the Start > Programs >mSupply (on Windows). If this is the first 
time mSupply has been started after installation, then an example data file 
will be opened allowing you to follow the mSupply tutorial. mSupply will 
present you with a log in window.

Single-user systems: Note that mSupply will “remember” the last data file used, 
and automatically present the log-in window for that file unless you move or 
rename your data file. If you do this, mSupply will show you a standard open/
save window for you to choose the new name/location of your data.

Single user: Creating a new data file
If you would like to create a new data file now, then log in to the example data 
file and from the mSupply menu do the following.

• File > New Data File...Navigate to a convenient location. Assign a name to 
your data file and click the save button. mSupply will now start creating a 
new data file.

• You will be presented with a login window. See next page for instrucions • Click on the “New” b
Another window wil
of your new data.

Once mSupply has opened 
file which is opened autom
it must be chosen, as describ
to a different location, it m
10

• Start entering your data.

Alternative method for creating a new date file
Here is an another way to create a new data file.

• Quit mSupply if it is running.

• Start mSupply and then immediately hold down the “alt” key (You will 
now be shown the window to choose a data file. This window has a 
“New” button allowing you to create a new data file if you wish. 



 

Log-in to mSupply-HIS
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Starting to use mSupply-HIS

        

Now, click “OK” to login
Log-in to mSupply-HIS
Double-click the mSupply (or mSupply Client) icon on your desktop. The first 
time you use mSupply, you will be presented with the log-in window like this:

User name
You should select your name from the list 

Password
Enter your password

Store/Mode
We will assume you only have access to the HIS module, in which case when you 
clicked on your name, the correct store/mode will have been chosen for you.



 

Starting to use mSupply-HIS
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Setting up Wards and Beds

  

 description. You can also add a note if you want to.

nore the coordinates.

 information and close the window.

t  for each ward.

  

e set up wards before setting up beds.

ow beds...

Click Ne d a bed.
e name and

, you can ig

 to save the

he process

re you hav

Special > Sh

w Bed to ad
Wards
Choose Special > Show Wards

You will be shown a window like this:

Click New Ward to add a ward.

Fill in th

For now

Click OK

Repeat 

Beds
Make su

Choose 



 

Setting up Wards and Beds

         

de, type as much of the code or description as you 
s will be shown. For example, typing “foot” will show 
 in their code (not that many, we imagine”!) or their 

e 

 

New

 

 button.

’s details, double-click the row.

  

 a code up until a certain date.

ou can’t assign that code to any new encounters.

eld to disable use of a code at any time by entering 
 the record.

  
Fill in the bed number (or name).

If your wards have rooms, you can enter the room number or name. This is 
optional.

Choose the ward the bed is in from the drop-down list.

Click OK to save and close the window.

Modifying wards and beds.
To modify a ward or bed, show the list from the Special menu, then double-click 
on the entry you wish to modify. 

Note that if you modify a ward or bed, all historical records will be updated. 
Therefor, don’t change the name of a ward to a totally different name, and 
don’t move a bed to a different ward.

ICD10 Disease codes
See the File menu chapter for instructions on importing a 

An ICD10 disease list is available on the mSupply web site.

Show ICD10 codes
On choosing Special > Show ICD10 codes you will be shown the current disease 
list.

Find
To search for a particular co
know, and matching entrie
all entries that have “foot”
description.

To Add a new entry, click th

To Modify or view an entry

Valid until...
This field allows you to use

After that date is reached, y

Note that you can use this fi
yesterday’s date and saving
Setting up user access
14
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Preferences...

       

Max picture size

 

Enter the maximum size of patient pictures that can be inserted. We suggest you 

  
Choosing the Preferences menu item from the file menu opens a window with a 
side bar. Clicking on a subject in the side bar shows the options for that subject:

General

Organisation name
Enter the hospital name here.

Country
Enter the country you are located in.
set this value to 500KB.

Maximum number of users.
Enter the maximum number of users that can log into the HIS system at one 
time. For example, if you purchase a 10 user license, and assign 6 users to the HIS 
system, it will allow 4 users to log in to the pharmacy (mSupply) module.



 

Preferences...
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Working with lists

     

 of columns you are currently using.

f available columns. To add a column to the view, click on 
-hand list, then click the right--pointing button in between 
ntrol-click to add multiple columns at the same time.

n select the column(s) to remove from the right-hand list, and 
ng button to move the columns back to the available list. You 
 first column in chosen list, as it is a hidden key column to 

 niquely.

 

Renamin

 

n  a field name in the right hand list you can change the col-

 

 

 

set column widths is to drag the dividers between the col-
..

a al column width is too wide for the window, a horizontal 
ight is a list

eft is a list o
 in the left
 You can co

ve a colum
 left-pointi
remove the
each row u

g columns
g twice on

e.

widths
est way to 
 the list view

t if the tot
Whenever you perform a search in mSupply resulting in more than one item 
being found, you will be presented with a list of records (be they items, names, 
contacts or another list) that matches the criteria you entered.

mSupply uses two types of list display. Shorter lists, such as those you see when 
you view an invoice, or view the stock for an item employ a list with a striped 
background. These lists have resizable and moveable columns, and have an indi-
cator to show the sorted column. Their use is discussed in the next chapter. In this 
chapter we are concerned with tools for handling lists of names and items and 
transactions, which run into hundreds of thousands or millions of records.

When these lists are displayed, a series of buttons are present along the top of 
the window, as shown:

On the r

On the l
the item
the lists.

To remo
click the
can not 
identify
Customising the columns viewed
Clicking the Customise list button in the toolbar will display this window:

By clicki
umn titl

Column
The easi
umns in

Note th
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 reflect the type of records you are viewing. The list 
 by a particular field, double-click it in the left-hand 

“stock_on_hand” field results in thiswindow:

 the right, or click the right-pointing arrow after high-
t)

elds by adding further fields to the right-hand list.

scending ordering
by Fields” list has a small triangle to the right. If 
ill be ascending. If pointing down, descending.

ck on the triangle.

ht-hand column, then click the red single left-point-
scroll bar is added to the list allowing you to view columns to the right of those 
displayed.

Choosing the column order
To change the sequence of the columns in a list, drag a column header to a new 
location. This is done when viewing the Item list window, not in the Customise 
columns window.

Viewing or editing a particular record
To view or edit a record, double-click the row in the list you wish to view. A new 
window will open showing the details of the record you clicked.

Ordering (Sorting) lists
Ordering a list is the same as sorting it. Frequently a column may be ordered by 
clicking on the column heading. The column will be sorted in ascending order. 
Ascending means:

• A > Z (upper and lowercase are not considered different)

• 1 > 2 > 3 for numbers

• earlier dates to later dates

Descending means the opposite of Ascending.

Note that ordering a list does not add or remove any records from the list. It sim-
ply changes the order in which the records are displayed.

Should you require two (or more) sort parameters, clicking the Order by button 
shows the Order by window:

The Available Fields list will
shown is for Items. To order
list; double-clicking on the 

(You can also drag fields to
lighting the field on the lef

You can order by multiple fi

To change to ascending/de
Each item in the “Ordered 
pointing up, the ordering w

To change the direction, cli

To remove a field
Highlight the field in the rig

ing arrow between the two lists. The double left-pointing arrow will clear the 
“Ordered by Fields” list

rmula, click the Add formula button. Here the for-
 the formula “Length([items]code)” has been 
18

Using formulae
If you want to order by a fo
mula window is shown, and
entered.



Finding records

 there are four areas from which you have to choose or set a 
of a query.

elds,from where you make your selection
from where you select the one appropriate
re you enter your specific criterion
 with more than one criterion, click Add line, .then ....
 appropriate conjunction.

 want to find all items whose default pack size is greater than 
e starts with “A” these are the required steps

efault_pack_size” in the available fields list.
 greater than” in the Comparisons list
 (no quotes) in the value field.

2

4

Using this formula would allow you to identify items whose item code is shorter/
longer than your organisation’s specifications.

Click the OK button to close the window.

Once the details are entered, click the Order by button to order the list.

Finding records
In the item list shown above there is a Find button.

This button shows a simple find window where you can enter the start of the 
item name or code.

Within this window
value for each line 

1. Available fi
2. Operands, 
3. Value, whe
4. For queries
5. ..... click the

For example, if you
ten and whose cod

1. Click on “d
2. Click on “is
3. Enter “10”

1

3

5

19

Complex finds

4. Click the Add line button
5. Scroll down the available fields lists then click on “code” in the available

 equal to” in the Comparisons list
 (no quotes) in the value field.
uery button to perform the query.

indow would look like this
The window shown above has a Complex find button. This allows you to per-
form a search using multiple criteria. Clicking this button shows the query editor

fields list.
6. Click on “is
7. Enter “a@”
8. Click the Q

Before step 8, the w



Working with lists
The upper area of the query editor shows a summary of the query that is about 
to be performed.

Note that the wildcard character “@” has been used following “a” to find all 
items whose code has “a” as the first character

This example will return a list of items where both the search criteria are met, 
because the conjunction And was used. If you wanted to find items that 
matched only one of the criteria entered, you would click on the second line in 
the large upper panel to select it, and then click on the Or button where the 
conjunctions are displayed.
Saving and Using saved queries
If you have spent time on developing a particular query , and you are likely to 
20

use the same query in the future, click the Save button. You will be asked to 
choose a name and location to save the query. The saved file is very small. 

When a blank query window is first shown, you can re-use a previously saved 
query by clicking the Load... button and locating the query file.
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Patients: using, adding and editing

Type the Last name then a comma, then the first name (or part thereof), and 

i modifying patients
ow names

tient’s details, double-click on their name in the list.

Finding 
n, and a small window is shown:
ng and 
Patient > Sh

r view a pa

patients
 Find butto
Adding a new name.
Choose Patient > New Patient, or click the New Patient button on the names list 
toolbar.

Most of the fields are self-explanatory..

Note that the following fields are compulsory:

• First & Last name

• Address 1

• Date of birth.

Next of kin
Here you can link a patient to another existing patient. 

Show
Choose 

To edit o
press tab. A list of matching names will be shown. Double-click on a name to 
select that person.

Patient picture
You can add a patient picture by clicking the Add button. 

Click the



Patients: using, adding and editing
Type as much of the Last name, First name or Code as you know, and matching 
patients will be shown.

Note that you can search all patients or only in the already displayed list (the 
selection).
22



Encounters

 field, and you can type as much of the code or 
atching records.

 wish to use in the list.

dary/tertieary for disease rank.

 record.

a clicnician who diagnosed the condition if you want 
 of the name and press <tab>... a list of matching cli-
The second tab shows the disease records entered for this encounter.

Clicking the Add Encounter Disease button will show this window

The cursor will be in the ICD
name as you know to find m

Double-click the record you

Choose from primary/secon

Enter any notes you wish to

You can enter the name of 
to.. To do so, enter the start
nicians is shown.
24



Adding disease records.
Double-click on the clinician you wish to choose.

If you want to add a new clinician, click the New button. A window to enter the 
clinician’s details is shown:
25

Enter details and click OK.
Once you have entered the disease details, cliick OK to close the list of dseases 
for the current encounter.

You can now click the Add encounter disease button again to add another dis-
ease, or double-click an entry to edit it.



Encounters
26
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Report Menu

On selection of this option, the print window will be displayed. The preview of 

ecked, you will first be asked to save the report. Once you 
e, the report will be saved, and then automatically opened in 

se this option, mSupply may ask you for the location of your 
m, which it will then store for future reference.

so be set by choosing File > Preferences and clicking on the 
b.

 
cted, your report will be saved with extension “.html”. Hence, 
 any web-browser or spreadsheet application on any plat-

 ystem.

 
 saved to a file as a tab-delimited text file. (That is, a tab char-
 column and a return character at the end of each row). 

v n open the file in a spreadsheet or word processing pro-

at information will be displayed at the top and bottom of 
g ault report heading is set according to the report you are 

, the date will print on the left and the page number on the 
age.

 a default header and footer in the Preferences, these will be 
 left (for the header) and the bottom centre (for the footer)

Preview before printing
n print preview. Note that you can also turn on print preview 

e ow that is displayed after you click the OK button.
is box is ch
en it a nam
eet form.

 time you u
eet progra

tion can al
mputer” ta

HTML file
tion is sele
 opened by
operating s

Text file 
ort will be
tween each
ing, you ca

and footer
 choose wh
e. The def

. By default
t of each p

ve filled in
d at the top

 on screen 
ion turns o
 print wind
Alternatively, many reports are available from the Reports page of the Naviga-
tor, as shown below:

Report printing options...
Many of the reports below present you with a window like this before printing 
the report:

This window allows you to set various options:

Report destinations

Printer

When th
have giv
spreadsh

The first
spreadsh

The loca
“This Co

Save to
If this op
it can be
form or

Save as
Your rep
acter be
After sa
gram.

Header 
You can
each pa
printing
top righ

If you ha
displaye
the report can be displayed by turning on the print preview.

Open in Excel
If the ‘Open in Excel’ box is checked, mSupply will immediately open the report 
as a spreadsheet in MS Excel, provided MS Excel is installed on your computer; 
this feature also opens the report as a spreadsheet in Staroffice/Openoffice. 
[We’ve included special code to make sure they open using the “Calc” module of 
these applications.]

This opt
from th



Report Menu

f you want to report on records meeting specific crite-
ll be presented with the Query (search) editor, where 
statements to your heart's content! A short descrip-
ry editor is given below, and two example searches 
or a more comprehensive description, a range of 
her in electronic or hard copy versions. Please email 
 for more information.

n" is the group of records that were last displayed. 
 use the Item | View or edit item command quickly to 
 with "a". When you click the OK button, the items in 
nt selection". If you are not sure which records repre-
tion, you should click the "new search" radio button. 

 OK button you will be presented with the report edi-
n design a report. The report editor is somewhat com-
ent in learning how to use it is time well spent. It is a 
aluable feature. A brief introduction together with 
ple reports are given in Designing a Report below, 

 are available in training courses on using mSupply, 
ns available from Sustainable Solutions. 
ve a report or search (query), you can save them on 
nd retrieve them next time you run the report.
port you have created in the Custom reports folder it 

he report form. drop-down menu on future occasions 
e custom report
e any reports in the reports folder - these reports are 
Custom Report... 

The custom report window is displayed and this allows you to create a report 
according to your own requirements using the quick report editor; once created 
you may save the form of the report in the custom reports folder for future use

The window requires you to make three choices:

Report table
A list of tables on the left to choose which table (which type of records) you 
want to report on, e.g. Names, Items, etc. 

As of version 1.6 there are two options for transaction lines. The “Transaction 

• New search (query), i
ria. If chosen, you wi
you can build search 
tion of using the que
are later described. F
books is available eit
info@msupply.org.nz

• The "Current selectio
For example, you can
find all items starting
the list are the "curre
sent the current selec

Report form

• New report 
• After clicking the

tor where you ca
plex, but time sp
powerful and inv
designing two sim
and more details
and in publicatio

• If you want to sa
your hard disk, a

• If you save the re
will show up in t
when you choos

• Note: Do not sav

lines (Transaction query)” option allows you to search much faster on a large 
number of transaction lines. For example, if you are wanting to get the quantity 

reserved for special use, and modifying them could create problems! 

• New label layout
h the label editor, where you can design and save 
se are useful for use with names for addressing enve-

tems for making tags for labeling shelves in your 

s option the "Order by" window will appear after a 
s you to sort the records into a particular order before 
n a nutshell: Drag fields from the list on the left to the 
o use them for sorting)
e menu
28

of each item given to customers in a specific month, you would use this option.

Which records
A series of radio buttons to choose which records to examine 

• All records

• presents you wit
label layouts. The
lopes, and with I
warehouse. 

• If you choose thi
query. This allow
printing labels. (I
list on the right t

• other items in th



Custom Report...

• if you have saved any reports in the custom reports folder which is in 
the same folder as the mSupply application, they will be listed here.

e Custom Report editor, it is ready to take input values for a 
uery. Each line of a query needs 4 items of information:

uery. Choose this by clicking on the field in the middle-left list 
 above the list of fields is a drop-down list that allows you to 
elds from related tables. If you want to perform related que-

d to know a little about the internal structure of mSupply 
contact us if you would like a diagram of the table layouts. A 
ple of a related table is that each transaction line is related to 
 (many to one relationship). The means that you can use the 
stored in the transactions table (eg invoice date, number, sta-
uery transaction lines.

ator. Choose the comparator from the list of fields under 
For a list of the fields in each table, and what each field contains, see the Field 
Descriptions chapter in this manual.

Using previously saved layouts
Any report layouts which you have used previously, and saved, may be accessed 
by clicking on File >Open on the menu bar, and selecting the required layout.

Available methods

Using the Query Search editor

When you open th
simple single line q

• The field to q
of fields. Just
also choose fi
ries, you nee
data. Please 
simple exam
a transaction
information 
tus, etc.) to q

• The Compar

Method Description Parameters

date_day_number_to_text

qr_account_code_return

qr_flag_value_change

qr_get_currency

qr_get_location-from_key

qr_get_loc_from_key_new_process

qr_get_Name_code_from_key

qr_get_stockOnHand_from_itemKey

qr_get_store_name

qr_keep_accumulative_value

qr_ns_customer

qr_responsible_officer

qr_ship_method
29

The query editor can be a bit daunting, but is also very powerful and once you 
are familiar with its capabilities, your competence to access the precise informa-

"Comparisons" on the right by clicking on the comparator you wish to use.

lue. Is entered in the bottom area (above the buttons). In the 
ve, the field chosen is an alphanumeric field (the item code), 
rea is displayed where you can enter text or a numeric value - 
ce the item code "gri250t" has been entered. Note that you 
the "@" symbol as a wildcard in your query value to perform 
ueries.
tion you may require from within the mSupply database will significantly 
increase. Two examples will later be described, but here we look at a query 
about to be performed on the items table:

• The Query va
example abo
so an entry a
in this instan
can also use 
"contains" q



Report Menu

indow allows you to customise the built-in reports 
 create multiple versions with different display for-
n the report is run.

ort management process, see the mSupply user 
• The Conjunction. This does not apply to the first line of a query, but the 
second and any further lines need to start with a conjunction. Set the con-
junction for the selected line by clicking the appropriate button in the bot-
tom-left area of the window ("And", "Or" or  "Except")

To add lines to a query, click the "Add Line" button.

If you have spent time creating a complex query that you might wish to use on 
future occasions, you can save it to your hard disk and select it again using the 
"save" and "load" buttons in the window.

Once your completed query is entered, click the "Query" or "Query selection" 
buttons to proceed.

Designing a Report
See the mSupply user guide for a tutorial in report design.

General Reports
Choosing this item shows a list of common reports.

All wards
Prints a list of Wards.

All beds
Prints a list of beds

Currently admitted patients
Prints a list of patients who have not yet been discharged, along with their ward 

Manage Reports

The report management w
available in mSupply, and to
mats that are available whe

For a description of the rep
guide.
and bed and expected discharge date.
30

Discharged patients
Prints a list of discharged paitents for the date range specified.

Ward occupancy rate
Print the occupancy rate for each ward for the period speicified.



Manage Reports
31
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Warning:: Do not try to open the same data file from 2 or more single user copies 
of mSupply at the same time. You will corrupt your data. If you require multi-user 

e ring your computer, choose this item before you 
 the next user will have to log in with their user name 
 access. 

t es you the option of quitting mSupply or re-entering 
rd. This stops a new user canceling the window and 
under your login details. 

This menu item hose permissions allow switch stores and/or login 
mode without th re-enter their password. Note that this screen does 

 pressing Cancel reverts to the current store/login 
n his feature should be exercised, and this screen 
i en the computer is left unattended.
 user is sha
ter so that
re gaining

 button giv
and passwo
e mSupply 

lets a user w
e need to 
ge of user;
 in using t

splayed wh
File menu...

New data file…
This command only applies to single-user operation

This command will present you with a standard open/save window where you 
can choose the name and location of a new data file:

If you click the OK button, mSupply will close the data file currently in use (sav-
ing any changes made automatically), and then open the new data file.

The new data file will contain no names or transactions. You can either enter 
these manually or use the import commands (see later in this chapter) to import 
names, .

Open data file…
This command only applies to single-user operation

This command will present you with a standard open/save window where you 
can select an existing data file to open. 

If you click the OK button after successfully selecting a valid mSupply data file, 
mSupply-HIS will close the data file currently in use (saving any changes made 
automatically), and then open the new data file.

Note that if you regularly use more than one data file, use the “About mSup-
ply…”. Command from the help menu (mSupply menu on Macintosh), where 
the data file currently in use is displayed.

If more than on
leave the compu
& password befo

Clicking the Qui
your user name 
continuing to us

Switch ....
access, buy a multi-user licence!

Change user
This menu item allows you to change to a different user without quitting mSup-
ply. 

not allow a chan
mode, so cautio
should not be d



File menu...

..
 show the current user (in case you've forgotten your 
tant to ensure that you do not start to use a compu-
lready logged in to mSupply, or else your work (and 
 to the person who was logged in.

up of your datafile to be made to the specified loca-
ackup path can be set from File> Preferences.You can 
 as well as automatically. It is not necessary to quit 
ming a backup.

oth in single user as well as multi-user mode. Under 
and performs a backup of the server data. A 

 how the backup is proceeding.

 you can’t run “Backup“ and “Restore“ functionfrom 
Change Password
You can change your password using this command. You must know your old 
password to do this.

 
You are required to enter the new password twice to ensure you have typed it 

Show current user.
A small window appears to
name!). Actually, it is impor
ter where someone else is a
mistakes!) will be attributed

Backup......
This function allows a back
tionin your computer.The b
perform a backup manually
the database before perfor

“Backup” function works b
multi-user mode, this comm
progress window will show

Note:- In multi-user mode ,

correctly. the client . This should always be run from the server computer.

ou to choose a backup data file,;uncompress it and 
ata file.

mmand will have no effect.

ring. We suggest you consult Sustainable Solutions 
.
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Note: passwords are case sensitive- make sure you don't have Caps Lock on. If 
you forget your password you must ask the user who is either first or second in 
the password list  to change your password for you. 

Edit users and groups... 
For further information see Restricting User Access on page 113.

Restore...
Choosing this item allows y
start using it as your main d

In client/server usage this co

Be very careful about resto
before attempting a restore



Import ICD10 codes...

Import ICD10 codes...

If you have a tab-delimited text file with 2 columns, you can import codes suing 
this command.

A sample ICD-10 file with 65000 codes is available on the mSupply web site.

Preferences
See the preferences chapter for more information.

Exit/Quit
This command will exit mSupply-HIS. 

There is no need to save your work. mSupply does this automatically.

Column 
number

Column 
letter

Field Description

1 A ICD10 
code 

8 alphanumeric characters (must be 
a unique value) 

2 B disease 
descrip-
tion

30 alphanumeric characters 
41



The Edit Menu
The Edit Menu 

The commands in the Edit Menu can be used when you are entering text, just 
the same as in a word processor. 

Undo: The previous contents can be retieved if the document has not been 
saved.

Cut: Deletes the currently selected text and places it on the clipboard

Copy: Copies the currently selected text and places it on the clipboard

Paste: Replaces the selected text (if there is any) with the contents of the clip-
board. If there is no selected text, the clipboard contents are inserted at the 
insertion point (the blinking cursor)

Clear: Clears the text in the particular field.

If the copy/cut/paste items are dimmed out,  it is because you are not currently in 
a text entry field. 
42
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The Special menu

der, click the New reminder...” button at the bottom of the 

 double-click it in the list.

er, click on the reminder to delete, then click the Delete but-

 by clicking on the column headers. Click a second time to 
h  direction.

 reminders displayed according to the status and whether 
you to complete or was created by you.

lete or in-complete reminders, choose from the status drop-
 new remin

 reminder,

e a remind

 sort the list
e opposite

 the list
 change the
inder is for 

 only comp
t.
Show Navigator
If for any reason the mSupply Navigator is not visible, choose this option to show 
it again. 

set the width and height of the labels you are using in millimetres.

Dn you are finished editing currencies.

Wards, Beds, Diseases
See the chapter on setting up mSupply-HIS for info on these items.

Reminders...
The Reminders command shows reminders that are not yet completed.

To add a
list.

To edit a

To delet
ton.

You can
sort in t

Filtering
You can
the rem

To show
down lis



The Special menu

e being possible only when that store contains zero 
no transactions recorded.

 list of previously saved label formats.

 list to edit/print that format, or click the New button 
ormat details window looks like this:
The Reminder details window

Date
The due date of the task

Reminder for User
By default you create reminders for yourself, but you can also create them for 
other users. If you’re the micro-managing type, you could put everyone else’s 
work plans in for each day or week!

Note
The text of the reminder message

Note that deletion of a stor
stock and there have been 

Misc labels
Choosing this item shows a

Double-click an item in the
to add a new format. The f
Completed

he label- it is for you to identify the label. It is shown 
44

Check this box if the reminder is completed (but note that it won’t usually show 
in the list once is is checked)

Repeats automatically
Once this box is checked, you will be shown options for the reminder to repeat 
daily, weekly or monthly.

particular store from this window; its purposes are these:- 

• to create a store
• to display the created stores
• to edit or delete a store

Label name
This field will not print on t



Clinicians...

in the list of available formats when the Misc labels menu item is chosen.

riber, click the “New” button.

 presciber. You can use the code quickly to look upthe pre-
sing.

rly self-explanatory. Note that the code, first name and last 
d for looking up prescribers when dispensing.
Heading, Body, Footers
These fields will print on the label in roughly the position that they are on the 
screen. Note that if you enter a very long left and right footer they may overlap 
in the middle of the label. Print a single test label to check first.

The labels are designed to print to plain 90mm x 40mm (w x h) labels from a 
Zebra label printer. Please contact us if you require support of other printers and 
other label formats.

Print button
Clicking this button will print the number of labels specified in the quantity to 
print field to your label printer. If the print preview button is checked, you will 
be shown an on-screen preview of the label. Note that if you enter a large quan-
tity and check the preview option, you will be shown a preview of each label!

Cancel button
Clicking Cancel will close the window without saving any changes you have 
made

Delete button
Clicking this button will delete the currently displayed format and return you to 
the list of available formats.

OK button
Clicking OK will save any changes you have made and close the window. (Note 
that the quantity to print is not saved- it is reset to 1 each time you open the 
window).

Clinicians...
We were going to title this section “Managing Prescibers” but we all know that’s 

To add a new presc

Add a code for the
scriber when dispen

Other fields are fai
name can all be use
45

not possible ;-)
Initials

 the “Initials” field will print on dispensary labels.

iber that is no longer used, you can change their status to 
prescriber will not show in the choice list when dispensing. 
 will still show when you choose Special > Show Prescibers...

ght want to add a “Miscellanous Prescribers” item to the list, 
When you are in dispensary mode, issuing items to a patient allows you to add a 
prescriber. This menu item allows you to set up your list of prescribers. The text you put in

Active status
If you have a prescr
“inactive” and the 
Inactive prescribers

We suggest you mi



The Special menu

reate a new category.

d to customer, customer credit, supplier, supplier 
ory adjustment while creating or editing transactions.

egories they will show as a drop-down list when you 
and use this if you have a lot of prescribers whose prescriptions you only dis-
pense infrequently.

Category
This field can be used to group prescribers together, and can then be used to fil-
ter prescribers when producing a transaction report.

Merge prescribers
This menu item is used to merge two prescribers, where the same prescriber has 
inadvertently been entered twice. You are shown a window like this:

Enter the two prescriber names by entering the start of their surname or their 
code, and then pressing Tab. The top prescriber is the one who will be kept. The 
lower prescriber will be deleted.

Once you have entered the two names, check the details are correct, and then 
click OK. You will be warned one last time, and then the operation will be com-

Click on “New” button to c

The categories can be adde
credit, repack, build, invent

Once you have assigned cat

pleted.

All transactions that recorded the deleted prescriber will now show the name of 
enter a new invoice or transaction.

r to v1.8 categories were set in the Preferences, and 
for supplier and customer invoices).

indow where you can edit contacts.
46

the prescriber that was kept.

Transaction categories
Categories allow you a way of grouping transactions together. Each type of 
transaction can have its own list of categories. For example customer invoices 
might have a category “normal” and “urgent”. Inventory adjustements might 
have categories “expired”, “damaged” and “stock take”

(In versions of mSupply prio
there were only categories 

Contacts...
This command displays a w



New e-mail...

• If you choose labels, you will be shown the label editor, allowing you to 
 address labels for the current list of contacts. Note that you 
rticular label layout and then use the "load" command in the 
o restore your layout.

ouble-click on the line you want to edit. You will be shown 

and reveals this window: 
Contacts are usually associated with a name (a customer or supplier), and it is 
easier to edit such contacts using the "show suppliers…" or "show customers…" 
command.

If a contact is not associated with a name, you can edit details for that contact 
using this command.

Buttons in the contact list window:

Query
Use to find the contacts you wish to report on or wish to produce a set of 
address labels for.

Report

print a set of
can save a pa
label editor t

New
To edit a contact, d
the contact details:

New e-mail...
Choosing this comm
47

presents the Quick report editor window. See the using the report editor chapter 
for more instructions.
Order by
sort the contacts

Print
clicking this button will present you with a dialog with two choices:

• If you click list a list will be printed of the records in the window.



The Special menu

addresses in the "CC" or "BCC" fields, or want to 
 the email, then click the small "plus" icon on the left 

 (See below for how to attach documents). To enter 
ss in the "CC" or "BCC" fields, separate the addresses 

 message.

to queue your message. 

e, click the send button in the message list window, or 
il... from the special menu.

set a return address and a mail server in the Prefer-

l-up connection, you must close the connection when 
ding.

 attach documents to an email. 

t, simply click the "attach" button. You will be pre-
dard window to find a file.

e number of attachments you can add to a email. 
ew thousand. Let us know if this isn't enough.)

ent, click the attachment in the list you want to 
 delete button.
The email window allows you to compose and then send an email from directly 
within mSupply. 

The inbuilt email sending functions of mSupply allow you to:

• Send invoices to customers that they can print (using the "export HTML 
invoice" command)

• Send orders to suppliers (using either the "Email" or “Email pdf” menu 
item when editing an order)

• Send electronic invoices to customers that they can automatically import 

• If you want to enter 
attach a document to
to show those fields.
more than one addre
with commas. 

• Type the text of your

• Click the OK button 

• To send your messag
choose Send queued ma

Notes:

• Make sure you have 
ences.

• If you are using a dia
you have finished sen

Attachments 

• mSupply allows you to

• To attach a documen
sented with the stan

• There is no limit to th
(Well, actually it's a f

• To delete an attachm
delete, then click the
into their copies of mSupply. Show e-mails...
ter the number of days of mail to display. The default 
ast week.
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• Send an email as you would using another email application. If you use 
mSupply, the advantage is that the email can be linked to the name, and 
easily viewed from the Email tab of the name details window.

To compose an email 

• Enter the recipient email address in the to field. If you have email addresses 
entered for names in mSupply, type the start of the name, and click the find 
button to automatically insert the address. To enter more than one 
address, separate the addresses with commas.

• Enter a subject in the subject field

You will be requested to en
will display all mail for the l



Send queued e-mails...

e list window:

e, click on it to highlight it (control-click (Mac: command-click) 
essages). You will be given a warning allowing you to 

age you have highlighted will be made, and will open in the 
on window to allow you to edit it.

l be created, and the message composition window will 
 to edit it.

ill open, allowing you to find messages. The results will be 
.

f messages will be printed.

e-mails...
ed messages will be sent. If you have a dedicated network 
ssages will be sent straight away. If you have a dial-up con-
e not already connected to the internet, you will be shown 
window to initiate a connection. 

 a long time to establish a connection, mSupply may give an 
eriencing problems, first establish the connection to your ISP, 
Viewing a messages
To view a message from the list, double-click it.

To view a different mailbox, choose the name of mailbox from the list 

Status 
The status of a message will be one of the following:

• S - the message has been successfully sent. Once a message has been sent 
you can no longer edit it. To send the same message again, use the duplicate 
button to make a copy of the e-mail.

• Q - the message is queued, and will be sent next time e-mail is sent

Buttons in the messag

Delete
To delete a messag
to select mulitple m
change your mind!

Duplicate
A copy of the mess
message compositi

New
A new message wil
open, allowing you

Find
The find window w
displayed in the list

Print
The displayed list o

Send queued 
Any queued e-mail
connection, the me
nection and you ar
the "connect to..." 

Note that if it takes
error. If you are exp
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• H - the message is on hold, and will not be sent.

You can click on the "status" and "date" column headers to sort messages by 
then choose Special | send queued e-mail.

ar stock...
 the start of year quantity for each item, and records the start 
tock date and stock quantity are used when printing a ledger.

 reset your starting stock on the first day of each new finan-
e end of the year, the item ledger will print the starting 
those columns.

To view a message, double-click it, and it will open in the message composition 
window.

Managing mailboxes
Click the edit button beside the drop-down list to show a list of mailboxes:

Set start of ye
This command sets
date. The starting s

The idea is that you
cial year. Then, at th



The Special menu

dit it.

t, then click this button to delete it.

 a new message. The window to add or edit a mes-
value, all transactions for the year, and your ending stock quantities.

Using this command does not change any stock-on-hand values or archive any 
transactions.

You are not required to use this command, but if you do not, you will not be 
able to archive transactions, and you will get very long item ledger printouts!

Show Web messages
If you are using the mSupply web server, web messages give you a way of giving 
information to your clients. For example, you might want to let them know 
about a change in packaging, a drug recall or that you will be closed next Tues-
day for stock taking.

The messages you add will be shown in the customer’s web browser after they 
have successfully logged in.

Double-click a message to e

Delete button
Click on a message in the lis

Click the New button to add
sage will be shown
50

Choosing this menu item shows a list of messages



View log

View log
iew log you will be asked how many days history to view (the 

 only be used by users in the "high access" group.

ignificant events, along with the date, the time and the user.

ow:

window

rt the log
Only messages with the “active” radio button checked will be displayed.

Priority
Choose a priorty from one to five. Messages are sorted by priority before they 
are displayed, so messages with a priority of “1” will display at the top of the list.

When a customer successfully logs on, they will see the headline message only, 
with a “more....” link, which will display the full message text.

Note that you can put HTML tags in the message headline and body.

For example, to make a message appear in bold, write it like this:

When you choose v
default is 7 days)

This menu item can

It displays a list of s

Buttons in the wind

• OK- exit the 

• Order by- so
51

• <strong>Urgent request for assistance</strong> • Search- find particular records in the log.

s you to export the log for use in another application

 item displays a report of the list of names of the users, their 
 status, number of logins, last login date and last login time.
To make a message blink:

• <blink>Blinking messages are very annoying</blink>

You can also use this facility to make complex newsletters with columns and links 
to other web pages etc. 

• Export- allow

User’s report
Choosing this menu
access group, active



The Help Menu

newer version is available for download).
The Help Menu

About mSupply...
Choosing this item displays information about the version of mSupply in use, 
and provides details of the location and size of your data file.

You can click the blue arrows icon to retrieve the current version number from 
the internet. (This will not download a new version- it will only advise whether a 

use it! 
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Authorisation
The Authorisation button is provided largely for developers’ use. Its purpose is to 
assist our technical staff to resolve clients’ problems. It is recommended that you 
ignore it.

Why is there no help option?
We haven’t included a help file in mSupply to keep download sizes small, and 
because we think that this PDF help file is a thing of beauty and you ought to 
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Miscellaneous Topics

On Windows:

n s
 are usually presented with two dialog boxes (Windows). The 
e setup" window. What this window looks like will depend 
u have chosen. The second box is the "print" window.

i  has a check box that allows you to preview each page 
ttons in the print preview window:

rints the current page

tops the print preview. Useful to view a report without printing it.

s page (left arrow icon)- Move to the previous page of the print job

ge - Move to the next page of the print job

Magnify the view, or see the whole page (if the view is already magni-
e

 have set the print preview to "on", the "print preview" check 
 cked until you uncheck it or you quit mSupply.

i ur data
 mSupply password system carefully, your data is fairly secure.

t if a person has access to the original copy of mSupply, they 
will easi o open the data file, as the "user 1" password is clearly 

n ord entry screen until it is overwritten the first time you click 
onsibility to keep copies of your mSupply software and data 

asswords stored in the data file are encrypted with strong 
ption, so there is little danger of someone finding your pass-
g note
rinting you
 is the "pag
h printer yo

nt" window
rinting. Bu

  Print - P

  Stop - S

  Previou

  Next pa

 Zoom - 
d).
t once you
remain che

ty of yo
aintain the

wever, tha
ly be able t
 the passw

 is your resp
 place. 

rsion 1.4, p
 RSA encry
Maintenance and Repair
If you are using your data file regularly, it is a good idea occasionally to check 
that no problems have developed. Problems can develop due, for example, to 
faulty hardware and other reasons outside our control.

For technically competent users or professional IT staff
In the case of a serious hardware failure, the first option should always be to 
revert to the last known good backup of your data.

If for some reason you must repair a damaged data file, please contact Sustaina-
ble Solutions for advice.

To check your data, download a product called 4D Tools. (4D Tools and a manual 
is included on the CD) from ftp://ftp.4d.com.

4D Tools can simply check your data file for errors, or repair your file. Please con-
tact Sustainable Solutions if you believe your data file has a problem, before 
repairing it.

Always use 4D Tools on a backup copy of your data first.

If 4D Tools is unable to repair your data, Sustainable Solutions is able to use spe-
cialist tools to examine your data, and even export your data and re-import into 
a new data file. We have not had to do this for a customer yet, but the option is 
available as a near-last resort.

How do I move a window whose title bar has been hid-
den?

Printi
When p
first box
on whic

The "pr
before p

• 

• 

• 

• 

• 
fi

Note tha
box will

Secur
If you m

Note, ho
• Method 1: Press Ctrl and both mouse buttons, and drag the window to the new loca-
tion.

• Method 2: Press Alt-Ctrl-right mouse button, while dragging the window to the new 
location.

On Mac OS 

• Press Control-Command-mouse button, and drag the window to the new location 

shown i
"OK". It
in a safe

As of ve
(512 bit)
word.



Technical Notes

me other that “C” depending on how your system is 

so installs the following files and folders:
ntaining mSupply reports and plug-ins in the same 

 first time
server, double-click the “Start mSupply Server” icon 

You can also star r by choosing Start > mSupply Server > mSupply 

e window where you should choose the “I would 
on” radio button.
y have a na

installer al
Plugins” co
er.exe

ver for the
u start the 

t the serve

n a welcom
th Dimensi

”

Technical Notes 

mSupply Client/Server installation
If you are using the client/server version of mSupply you will be supplied with a 
CD with 2 installers. One installer, mSupply_server_installer.exe is used to install 
the server software on a single server computer. The installer 
mSupply_client_installer.exe is used to install the client software on as many 
computers as you wish. You will be limited in how many clients can connect at 
any one time by the server licence you have purchased.

To run the installers, simply insert the mSupply CD, open Windows Explorer and 
double-click the installer file on the CD that you wish to run.

Installing mSupply server

Run the installer

(The volume ma
configured)

mSupply server 
A folder called “
folder as 4D serv

Starting the Ser
The first time yo
on the desktop
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What is installed where:
We strongly recommend you do not change the default installation directories, 
which are as follows:

mSupply Server: c:\Program files\mSupply\mSupply Server

mSupply Client: c:\Program files\mSupply\mSupply Client

Server

You will be show
like to activate 4

Then click “Next



mSupply Client/Server installation

own the window to generate a file.

ation here- just click the “Next” button.
In the next window you should read the agreement.Click on the “I agree” check 
box, and then on the “Next” button”

Then the activation mode window is shown.

You will then be sh

Do not enter inform
55

Choose “Offline activation” then click “Next”
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n.

a window with the following message:

 following window with the “Open a database” tab 
You will then be shown a window instructing you to send the generated file. 
Just click the “Next” button.

Then click the “Next” butto

You should then be shown 

You will then be shown the
selected.
Then you will be shown a window where you are asked to integrate the file 
received.

u will be shown an open/save window where you 
is located in C:\Program Files\mSupply\mSupply 
56

Click the “Choose File” button and choose the file sent to you by Sustainable 
Solutions.

Once you have chosen the file, it will show in the box in the window:
Click the Browse button. Yo
choose the program file. It 



mSupply Client/Server installation

server\Progam\mSupply.4Dc

ate a folder called “mSupply data” inside your “My Docu-
 can create the data file anywhere you like, but make sure 
e access to the directory or there will be problems.

ed the Save button you will be shown a message stating that 
een updated with new Preferences. 
Click the “Open” button.

You will be shown a window where you can choose or create a new data file.

Click the New button to create a new data file. Another window will be shown 
where you can choose the location and name of your new data file.

We suggest you cre
ments” folder. You
you have read/writ

Once you have click
your data file has b
57

nnect with the client software to configure the Preferences 
 enter the mSupply registration number. You will then be 
r admin interface:
You will have to co
for mSupply and to
shown the 4D serve



Technical Notes

r window
D 2004 server has an integrated backup scheduler. 
umentation from Sustainable Solutions regarding its 

s a service
et to start automatically when the machine is turned 
d by setting the server to run as a service. Choose File 

e as Service

dow by clicking the close box on the top right (or 
 menus). You will then be shown a disconnect win-

click OK. The server will quit.

inistrative interface by choosing Start > (Settings) > 
tive Tools > Services. 

con and choose Send to > Desktop (as shortcut). This 
Congratulations!

If you get a Windows Security alert
If you are running WIndows XP with SP2 or later installed you may get this alert:

About the backup schedule
The new version based on 4
Please request detailed doc
use.

Setting the server to run a
The server should now be s
on. This can be accomplishe
> Register Current Databas

Quit the Sertver admin win
choose File > Quit from the
dow:

Type “0” into the box, and 

Now open the services adm
Control Panel > Administra

Right-click on the Services i

will provide quick access this area in the future.

Double-click on Services in the list. You will be shown this window.
58

Make sure you click the Unblock button or the server will not function properly.



mSupply Client/Server installation

g on as” is set to “local system account”

low service to interact with desktop” is checked.

 the window.

he service by clicking the little play button (right facing trian-
 with the 4D service highlighted.

D server will start automatically when the machine is turned 
d to log-on to the machine.

 suggest you delete the Start mSupply server shortcut, as this 
 server as a service, and should not be used.

 manually stop and start the server in future:

e-click the “Services” shortcut you made on the desktop, highlight the 
ce, and click the “start” button (looks like a “Play” button on a VCR )

ver, make sure clients are not connected, then choose File > Quit on the 
Double-click on 4DServer:mSupply - fortunately it is usually the first item in the 
list!

You will be shown the 4D service properties window. Change the Startup type in 
the drop-down list to automatic.

• Make sure “Lo

• Make sure “Al

Click “OK” to close

You can now start t
gle) on the toolbar

From now on the 4
on. There is no nee

On the desktop, we
will not start the 4D

Should you need to

• To start, doubl
4D server servi

• To stop the ser
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server.

Next steps: install mSupply client then register mSupply.

erial numbers
d 4D server the licence allowed 2 concurrent connections. If 
 extra connections, you should enter the serial number(s) 

ate licence. This window is shown:
On the “Log On” tab, the settings should be shown below:

Entering Extra 4D s
When you registere
you have purchased
now.

Choose Help > Upd
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ick the “New” button. 

le, navigate to the file’s location then click the 

tings
s you may want to change are the memory settings 
l.

This window is shown:
Click the Add button to enter additional licences.

Creating a new data file or choosing a different data file
From this point there should be no need to revisit any of the about procedures 
to operate mSupply. However, if you are testing, or starting a data file for a sec-
ond organisation, you may wish either to change the data file mSupply is using 
or to create a new file.

The mSupply program (the files named “mSupply.4DC” and “mSupply.RSR”) 
store the path to the last data file used, and the next time mSupply is started, 
the previous data file that was open is opened again unless there is user inter-
vention or the “old” data file has been moved to a new location. 

To intervene, hold down the “alt” key as the 4D server starts up. 

You will be shown the standard open/save window:

To create a new data file, cl

To select an existing data fi
“Open” button.

Setting server memory set
The most important setting
and the cache flush interva

Choose Edit > Preferences. 
Click on the “Application” section in the left-hand list. Provided you have more 
than 256Mb of RAM installed, set the “Maximum cache” setting to half the 

if you have 768Mb, set it to 384000 Kb). This cache 
tegrated with the data stored in the data file, but 
 times, significantly speeding up non-Ind queries and 
e settings will have more effect in subsequent years 
r number of records to manipulate. In the first few 
ifferences will be negligible.

ry ....” setting determines how often the data on the 
ith the data in the cache. We recommend you set this 
ersion based on the 4D 2004 engine we intend to use 
hat records all unsaved changes and allows auto-
60

physical RAM installed (eg. 
memory is automatically in
provides much faster access
other procedures. The cach
once the system has a large
months the performance d

The “Flush Data Buffers eve
hard disk is synchronized w
to “2” minutes. (From the v
the ability to run a log file t



mSupply Client/Server installation

matic integration of the unsaved changes should there ever be a crash - e.g. in 
the event of a hardware failure or a sudden power outage)

You will either have to phone or email the information to Sustainable Solutions 
to obtain a registration code.

 is keyed to your organisation name and the MAC address of 
g either of these will require a new code, which we shall will-

es
u may want sytematically to go through the mSupply Prefer-
ppropriate setttings.

le
ould have a “clean” data file that is registered and is set up 

oes not have other data in it.

aller also installs the following files and folders:
\Network” in the Windows folder on the startup volume, 

work component files that need to be present for 4D to com-
P (and othe types of) network(s).

ts are installed on 4D client. Each time 4D client connects to 
that have been added or modified on the server are automat-
 client.

llers have been set up to overwrite existing files, so reinstall-
ill restore any potentially corrupted files to their original 
will not overwrite your data files, unless you have been wise 
ur data file “example data” and put it in the “example data” 

wn in the event of a power failure
r should be attached to a UPS. The UPS should be fited with 

ial, USB or network cable) that allows control software to 
 situation and shut down the server.
Installing mSupply Client
To run the installer, insert the mSupply CD, open Windows Explorer and double-
click the mSupply_client_installer.exe file on the CD. Once the installation is com-
pleted, double-click the “start mSupply Client” shortcut on your destop. The fol-
lowing window will appear:

The window lists available mSupply servers on your network. Click on the server 
you wish to connect to. Once you have connected successfully, the “Recent” tab 
will be shown first, and you can choose the server there. If for some reason net-
work settings have been changed, and you cannot connect from the “Recent” 
tab, remember to look at the “TCP/IP” tab as well.

Clicking the “OK” button will take you to the mSupply password entry window. 
For new data files, the password is “user1” for the first user in the list. Click on 
the first user, then enter the password and click “OK”

Firewalls and the like

Note that the code
the server. Changin
ingly provide.

mSupply Preferenc
Once registered, yo
ences and choose a

Saving your data fi
At this point you sh
ready to use, but d

mSupply client inst
A folder called “\4D
which contains net
municate over a TC

Note that no repor
the Server, reports 
ically copied to the

Note that the insta
ing the software w
state. The installer 
enough to name yo
folder.

Graceful shutdo
Your mSupply serve
a control cable (ser
detect a low power
61

To make it easy for you to connect, mSupply publishes details about available 
servers on a specific port. It is quite possible that products such as “Zone Alarm” 

In the UPS control software set the shutdown to start at least two minutes 
before the power will fail.

 file at that point. The file should contain the single line “net 
 where the service name is the name displayed in the proper-
le-click the service name in the services window. In the exam-

ce name is “4DS mSupply.4DC” (not to be confused with the 
and “Norton Personal Firewall” will block access to this port and stop discovery 
of the servers. Contact your system administrator if the list of available servers is 
blank.

Registering mSupply
The procedure is described earlier in “Preferences” chapter of the mSupply user 
guide.

Set it to run a batch
stop Service name”
ties when you doub
ple below the servi
display name)
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 Folder should be on a different volume from the 
se, and not on a different partition of the same 

 to provide complete roll-back functionality in the 
 Please consult Sustainable Solutions before turning 

s the frequency of the backups to be set - in the 
You may wish to test your typing skills by opening a command prompt:

mSupply Server backup configuration
This information applies to 4D Server. If you are using mSupply in Single-user 
mode, the backup Preferences are set using the menu File > Preferences.

Full database backup and restore functions are available, and it is not necessary 
to exit the database before performing a backup.

The files to be included in the backup are set in the application Preferences.

It is recommended that backups be performed automatically at regular intervals 
without user intervention.

Before performing a scheduled automatic backup, the required parameters 
should be set. Choose Edit > Preferences, then click on “Backup” in the left-hand 
pane. There are four sub-headings in the Backup Preferences section.

Configuration options

The Backup File Destination
one containing your databa
drive.

It is possible to use a log file
event of a system problem.
this option on.

Scheduler Options
The Scheduler option allow
Check the boxes adjacent to the files to be backed up ....... it is recommended 
that only the Data File box is checked.

above example, backups are made daily except Saturdays at 20:00 . Note that if 
Saturdays had been included, the “Every day(s)” option would have been 

 entered in the box.. Sustainable Solutions recom-
62

selected, and the figure “1”
mends daily backups.



mSupply file extensions and types

matic restore option for mSupply- if you should need to do a 
act Sustainable Solutions for help.

extensions and types
just for reference and to help your understanding. 

 and Windows OS - five files.

e (.4DC suffix)
Backup options
The Backup options window (shown below) allows the user to specify the 
number of backup files to be kept, and whether to create a backup in the event 
of no changes having been made since the previous backup (you can leave this 
unchecked).

We reccomend you keep 30 backups. 

The other available options are self explanatory, and the ones appropriate to the 

Restore options
Do not set the auto
restore please cont

mSupply file 
This information is 

On both Macintosh

•  A structure fil
63

user’s requirements should be selected. •  A structure resource file (.rsr suffix)

 file (.exe suffix)

DD suffix)

ce file (.4DR suffix)
• An executable

•  A data file (.4

•  A data resour



Technical Notes

 main tables in mSupply (There are some others, but 
 those!). This information will help you if you are 

d, finding information (querying) using that field 
File arrangement
It is easiest to keep all relevant files in the same folder, in a reasonably accessible 
place on your hard drive. (For example, directly on your "C" drive.)

If you make copies, don't leave them in the same folder, or you'll just get con-
fused!

There are several folders to store reports and queries that need to be in the 
same folder as your structure file. Note that these folders are automatically cre-
ated when you unzip the program files the first time. They are mentioned here 
so those of you with an inquisitive streak won't unknowingly do damage!

•  A reports folder. This stores reports that are used by the program. Leave this folder 
alone- store your own reports in the custom reports folder.

•  A custom reports  folder. Store the reports you create here.

•  A custom queries folder. Store the queries (searches) you create here.

•  A custom labels folder. Store any label templates you create here.

Note that on Windows or Macintosh the run time application (that is, the data-
base engine- "4Drun.exe" file on windows) can reside anywhere on your hard 
disk, and does not need to be regularly backed up (although you should have 
one backup copy somewhere!)

Getting the right data file when you open mSupply
Important! If you open mSupply by double-clicking the "start mSupply" icon on 
the desktop (Mac users- by double-clicking the structure file), mSupply will try to 
open the same data file that was last opened. It will open the same file each 
time if you repeat the same procedure. If you make a copy, and then double-

Field formats
The following tables list the
we're not telling you about
building your own reports. 

Note that if a field is indexe
will be very quick.
click the copy of the structure file, mSupply may still open using the data file 
64

from the original if it can find it. 

To choose the data file manually do this: hold down the option key (Mac) or Alt 
key (Windows) as you click the OK button in the password window. You will 
then be given an open/save box to choose the correct data file.

If you are not sure which structure and data file you are currently using, choose 
about mSupply... from the help menu (Windows) or the apple menu (Mac)



Field formats
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A
Att

C
Cat
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T

Clin
M

Col
C
R

Con
D
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Cus

D
Dat

C
C

Del
M

Des

E
E-m

A
D
N
N
S

Custom 28
Header and footer 27
Opening in other programs 27
Printing 27
Save to file 27
Saving as HTML 27

S
Search editor 29
Server

Running as a service 58
Service
dex

achments to E-mails 48

egories
nvoices 46
ransactions 46
icians
anaging 45

Status explained 49
Example Data file

Installing a new copy 9
Excel

Opening reports in 27

F
Files

Extensions 63
Finding records in Lists 19

H

Merging prescribers 46
Messages

On web interface 50
Microsoft Excel

Opening reports in 27
Miscellaneous Labels 44

Deleting 45

N
New data file creation 10

O

umns in lists HTML Reports 27 Ordering records in lists 18

 27

Running mSupply server as a service 
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Setup 8
Sorting records in lists 18
Special menu 43
Stock

Set start of year 49
Store

Choosing a different store 39

T
Transactions

Categories 46
hoosing 17
eordering 18
tacts
isplaying 46
ventions 7
tom reports 28

a file
hanging 64
reate new 10

eting
iscellaneous labels 45

I
Invoices

Categories 46

L
Labels

Creating with custom reports 28
Miscellaneous 44

Lists
Customising list views 17
Finding records 19
Reordering columns 18

P
Password

Changing 40
Password entry at startup 11
Preferences 15
Prescribers

Active chekbox 45
Merging, Deleting 46

Printing
Preview 53
Report options 27
Report printing options window
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igning a Report 30 Log U
User

Changing 39

V
Versions

Most recent changes 6

W

ail
ttachments 48
isplaying 48
ew 47
ew message 49
ending 49

Viewing 51
Login mode

switching 39
Log-in window 11

M
Mailboxes

Edit button 49

Q
Queries on lists 19
Query 29
Query editor 29

R
Reminders 43
Reports 27
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